Output Support

Installing Arcade

Upon starting your ARCADE subscription you will be provided with download links for both the Mac and Windows installers directly from your web browser.

Download links are also included in your order confirmation email and accessible via the ‘My Account’ section of our website. ARCADE is not downloaded through Output Hub.

After downloading the installer, follow the on-screen instructions to complete installation.

Note: Arcade must to be installed to your system drive. The installer will have the correct default path pre-selected, so you will not need to change this setting.

 

What’s Included in the Installer:

The ARCADE installer will provide you with all of the plugin files, the standalone application file, and 15 kits from our most popular Lines, so you can start playing with Kits and Loops immediately without the need to download anything.

NoteUnlike our previous Kontakt libraries, ARCADE is an instrument plugin unto itself and does not operate within Kontakt. As a result, ARCADE does not need to be activated in Native Access. All you need is an Output account and an internet connection. 

We also recommend using Arcade within a compatible Digital Audio Workstation (DAW) for the best experience. (DAW – FL Studio, Pro Tools, Logic, Ableton Live, Garageband, Etc.). 

 

System Requirements:

OSX 10.12+ AU / VST / VST 3 / AAX
WIN 7+ 64 bit VST / VST3 / AAX
8GB RAM required, 16GB recommended
* Arcade is supported by all major DAWs in 64 bit VST, VST3, AU and AAX format. There are certain systems that don’t play nicely with Arcade.

FL Studio: We strongly recommend enabling the ‘Use fixed size buffers’ option in the ‘Processing’ tab of the plugin wrapper.

Mixcraft 9 is compatible with Arcade versions 1.3.11 and below

The following systems aren’t currently compatible with Arcade
32 bit PC: Pro Tools 10. Cubase 8 (PC: VST, VST3). There are no known issues with Arcade running on Cubase 8 on a 64 bit machine.

Was this article helpful?
Have more questions? Submit a request