macOS Monterey & M1 Compatibility

 

Arcade

With the release of Arcade 2.3.0, Arcade is now compatible on both Apple Silicon (M1, M2 etc) as well as macOS 12 Monterey.  Please update to version 2.3.0 or higher for native support.  You can do so by downloading the Arcade updater from your Account Page under the Arcade tab.

Perpetual Software (Kontakt Engines + FX Engines)

Our team is still working to provide native support for Apple Silicon based Macs (M1, M2 etc) as well as macOS 12 Monterey.  Our perpetual software products are not currently supported in an official capacity. We will update this article once official compatibility is confirmed.

For more info on using Output software on M1 based Macs, please see this this article.

Was this article helpful?
103 out of 249 found this helpful

Articles in this section

See more
Our support hours:
Mon - Fri 6:00a.m. - 6:00p.m. PST Saturday - Sunday is limited availability