Arcade version 1.4+ and higher is not officially supported on Mac OS 10.9 - 10.11. 

Below you will find links for Arcade ver. 1.3 installers. Run the updater if you've had older versions of Arcade installed before. If you haven't had previous versions of Arcade on your machine, use the Full Installer. If you're downgrading from ver. 1.4+ to ver. 1.3, we suggest fully uninstalling Arcade first, then running the full installer.


Please note that as we work on releasing new updates for Arcade, support for these legacy versions may be limited.


Still have questions? Please click on the “Help” icon on the bottom right corner of this page to submit a ticket, and our team will follow up to assist!